Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-10-2002, 10:29 AM
Posts: n/a
Question K&N Air Filter Replacement Problem!!

I have replaced K&N airfilter for my 99 CLK320 last night but it turns out my outside temperature sensor becomes inaccurate. It stay in higher outside temperature then go down and up but it always remains higher than normal temperature. Does anyone have this kind of experience??
Reply With Quote
Old 09-10-2002, 01:59 PM
Posts: n/a
Question BTW, does anyone know where the outside temp. sensor located??

Reply With Quote
Old 09-10-2002, 04:04 PM
Jim's500E's Avatar
Large Member
Join Date: Mar 2001
Location: Manchester, Connecticut
Posts: 1,325
On my 92' 500E the outside temp sensor is under/attached to the front license plate holder...look around there for yours...and I don't think changing the air filter would screw up your outside temp sensor.

1992 500E
2007 CLK63
2003 Audi RS6
2001 Audi allroad
Reply With Quote
Old 09-11-2002, 09:17 AM
Posts: n/a
How is outside temp. sensor look like??

Check my sensor last night but couldn't find it. Does anyone know how is the sensor look like and any cable connect to it.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page