Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-28-1999, 10:47 PM
Posts: n/a
I have a 87 300e and it ildes fine when you first start and it's cold, but when its hot and you stop and leave for ten or twenty minutes and try to start it again it starts kind of hard and seems to miss for a few seconds some times it dies. I have replaced cap rotor spark wires spark plugs fuel filter and over charge relay.
Old 06-28-1999, 11:50 PM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Hi Dave
I have seen fuel pump check valve failed to
holding fuel pressure cause engine hard to
start when hot.
Just replace it,You can find that in partsshop.
Good luck to you.

MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner
Old 10-31-1999, 10:24 PM
Registered User
Join Date: Oct 1999
Location: OK
Posts: 33
I have this hard start problem too on 1989 300E. If this isnt a pro only repair can anyone describe how to change fuel check valve described above?

Thanks for replies.
Old 11-01-1999, 08:59 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The only other thing I have seen is the fuel injectors leaking down and the EHA leaking down. The EHA will visibly leak fuel if bad.

1981 280GE SWB
1987 16V

Old 11-01-1999, 11:36 PM
Registered User
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
If it is the fuel injector leaking, you should see black smoke out of the tail pipe with gasoline smell after the car is finally started.

Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
93 300E with idle surge and poor gas mileage 420sel man Tech Help 24 11-26-2009 01:22 PM
300TD Hot Idle Shaking - apparently solved surfblau Diesel Discussion 56 06-01-2009 05:41 PM
'93 300E running solution yet.. h.braich Tech Help 9 10-04-2004 11:02 PM
300E stumbles off idle Satch0922 Tech Help 1 08-25-2004 01:24 AM
300E Difficult Hot Starts Problem Solved elkadi Tech Help 5 08-28-2002 10:48 PM

All times are GMT -4. The time now is 05:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page