Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-28-1999, 11:47 PM
dave
Guest
 
Posts: n/a
I have a 87 300e and it ildes fine when you first start and it's cold, but when its hot and you stop and leave for ten or twenty minutes and try to start it again it starts kind of hard and seems to miss for a few seconds some times it dies. I have replaced cap rotor spark wires spark plugs fuel filter and over charge relay.
  #2  
Old 06-29-1999, 12:50 AM
Senior Member
 
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Hi Dave
I have seen fuel pump check valve failed to
holding fuel pressure cause engine hard to
start when hot.
Just replace it,You can find that in partsshop.
Good luck to you.

------------------
MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner
  #3  
Old 10-31-1999, 11:24 PM
Registered User
 
Join Date: Oct 1999
Location: OK
Posts: 33
I have this hard start problem too on 1989 300E. If this isnt a pro only repair can anyone describe how to change fuel check valve described above?

Thanks for replies.
  #4  
Old 11-01-1999, 09:59 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The only other thing I have seen is the fuel injectors leaking down and the EHA leaking down. The EHA will visibly leak fuel if bad.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #5  
Old 11-02-1999, 12:36 AM
Registered User
 
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
If it is the fuel injector leaking, you should see black smoke out of the tail pipe with gasoline smell after the car is finally started.

David
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
93 300E with idle surge and poor gas mileage 420sel man Tech Help 24 11-26-2009 02:22 PM
300TD Hot Idle Shaking - apparently solved surfblau Diesel Discussion 56 06-01-2009 06:41 PM
'93 300E running hot...no solution yet.. h.braich Tech Help 9 10-05-2004 12:02 AM
300E stumbles off idle Satch0922 Tech Help 1 08-25-2004 02:24 AM
300E Difficult Hot Starts Problem Solved elkadi Tech Help 5 08-28-2002 11:48 PM



All times are GMT -4. The time now is 08:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page