Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-30-1999, 02:50 PM
H20mobius
Guest
 
Posts: n/a
Have a 1984 190E 2.3 8 valve with 80k miles and was garaged for a very long time. The air conditioning isn't working also. When the air is "supposedly engaged" there is no drop in engine idle or additional strain on the engine and consequently no cold air. The temp of the air flow stays the same under all three button settings(the top, the snowflake, and the EC). Any ideas? Condensor? Coolant? Switch? Leak? Thanks.
  #2  
Old 06-30-1999, 10:04 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The most likely cause is low on freon.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SHOP MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM

  #3  
Old 07-01-1999, 05:28 AM
H20mobius
Guest
 
Posts: n/a
even though theres no "kick in engine strain" when the AC is selected?
  #4  
Old 07-01-1999, 10:17 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Yes, if the freon is low the compressor will never engage because of the low pressure switch in the drier.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SHOP MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM

Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Compressor problem Max J. Sandler Tech Help 8 06-20-2003 09:44 AM
A/C and heater problem Jackd Tech Help 26 10-31-2002 05:28 PM
a/c problem became less strange jivadent Diesel Discussion 2 10-30-2002 05:19 PM
Strange a/c problem on '86 300E can-do Tech Help 4 06-07-2002 01:12 AM
A/C problem has got me hot!!! Matt201 Tech Help 1 08-01-2001 12:39 AM



All times are GMT -4. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page