Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-02-1999, 12:05 AM
atdub@aol.com
Guest
 
Posts: n/a
My 88 420 with 149K has a slight "rock"
when I first turn it on: hot or cold start.
Its had this for a long time. MB dealer said I needed a valve job- that was 45k miles ago. Second MB dealer said it needed valve stem seals. That was done- car ran fine since. No more burning of oil.
The rock continues but diminishes slightly as the car is driven. Once in a while it will run perfectly smooth. Most of the time it has this "rock"- more obvious in neutral,
less in gear. 150K serivce has been done. Always dealer parts. Engine is smooth on acceleration and never misses, stalls, hesitates. Any suggestions?
  #2  
Old 07-02-1999, 12:36 PM
Senior Member
 
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Have you check your engine mounts... and also
1988 modle 420 SEL idle ca be raised 50 RPM
when transmission in gear ask a experince MB tech should know how to do it.

------------------
MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner
  #3  
Old 07-02-1999, 10:56 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The other thing to add to Mb stars is the injection nozzles. Have them checked too.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #4  
Old 07-06-1999, 11:23 PM
atdub
Guest
 
Posts: n/a
Motor mounts were done as was engine shock absorber. Great suggestion on checking the injector nozzles. I am 2nd owner-car has 149k- should they be cleaned (what method & tools), checked (what would you be looking for) or just replaced? Thanks in advance.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E320 16 PIN DTC Charts inc. pin 8, pin 14 cdanschwartz Tech Help 42 05-03-2016 12:06 PM
Oil Additives Bill Wood Performance Paddock 6 08-24-2011 11:53 AM
90 420sel engine noise SCOTTFISH Tech Help 3 12-14-2005 09:55 AM
300SEL / 420SEL - what body style / engine? yosshimura Off-Topic Discussion 2 08-02-2002 10:07 PM
'89 420SEL rebuild or junkyard engine? Aaron Tech Help 1 09-03-1999 10:42 PM



All times are GMT -4. The time now is 02:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page