Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-17-2002, 08:35 PM
Registered User
Join Date: Sep 2002
Posts: 2
Angry 83' Odometer Problem

I have a 1983 380 SL with an odometer reading of 265,000 miles.
It is more likely to be 365,000. I am looking to replace the odometer. I have looked online for parts. Is this a cable problem or a relay problem in the instrument cluster. The speedometer works fine. I can find nothing online regarding the odomoter. Does anyone know how this works ?
Thanks, Barbra
Reply With Quote
Old 09-17-2002, 09:57 PM
Join Date: Feb 2001
Location: Lakewood NY
Posts: 85
.This is a common problem on older models, like the 107 and 116, and an easy fix.
Remove the instrument cluster from the car and dis- assemble it till you get to the odometer assby. The problem is the gray metal gear on the number stack. It is supposed to be press fitted to the shaft and spin with the shaft, but over years and age and many miles it loosens up from the shaft and fails to function.
Fix it by pushing out the shaft with the correct size drill bit then support the number wheels with the shaft removed. Set the shaft next to the stack and note where the metal gear was positioned.Next take a punch and hammer and make a dimple on the shaft where the gear goes. Press the shaft back through the stack, re-assemble everything and the odometer will now work.
I have done this procedure on several cars and it works great.
Good luck:
J. William Tarbrake
NY State Dealer 7014303DLU
Registered repair shop R7014303
82 300SD modified for waste vegatable oil
92 300SE 270K miles perfect
79 450SEL (2 tone custom paint for special occations) SOLD
80 450SL
79 450SL 69K Miles FOR SALE
86 Carver 28 Voyager twin 270 Crusaders (SOLD)
94 CARVER 32 Voyager(SOLD)
67 Chris Craft 40' Aft Cabin(twin ford 427 side oilers)
Reply With Quote
Old 09-18-2002, 06:25 PM
Registered User
Join Date: Sep 2002
Posts: 2
Thumbs up 83 odometer problem


Thanks so much for the info. Will attempt this in the next couple of weeks. I'll let you know if it works out.
Thanks again,
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page