Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-06-1999, 01:44 PM
gp56
Guest
 
Posts: n/a
I've replaced both the radiator and the fan clutch. Temp stays below the 100 degree mark(line above the 80) regardless of traffic or A/C being on. After driving for about 45 minutes, temp will rise to about 110, regardless of speed of vehicle. Temp does not drop even on highway. If car is shut off, for lets say a half an hour, then the same sequence begins again as described above. Thermostat was replaced over a year ago. Aux fan is coming on but has no effect. Any ideas? Could T-stat be bad? All other components have been replaced in the past month. Prior to replacing radiator, temp would approach the red mark in traffic without the A/C on! Now it is much improved, but the above happens.
  #2  
Old 07-06-1999, 10:10 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Replace the thermostat at once! Be sure to put the bleeder to the top and to the right a little. What kills the thermostat is when the engine runs warm for long periods because of the faulty radiator.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1983 300SD or 1987 560 SEL BenzFreak Diesel Discussion 2 05-19-2003 02:05 AM
1983 300SD or 1987 560 SEL BenzFreak Wheels & Tires 0 05-18-2003 10:07 PM
Just added a 560 SEL jchip Tech Help 1 03-22-2003 10:44 PM
Wanted-1990/91 560 SEL in Toronto Canada Cigar Havana Mercedes Cars For Sale 22 01-31-2003 12:15 AM
RE: 560 SEL Overheating at Idle Marc P Tech Help 2 06-09-1999 11:22 PM



All times are GMT -4. The time now is 12:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page