Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-22-2002, 12:38 AM
Hou_Screw
Guest
 
Posts: n/a
Angry Lessons to learn by...

Ordered a used instrument cluster off this guy on ebay that sells a ton of them. My cluster's gears had obviously worn out cause it no longer turned any miles. (Common problem for the age I'm told) Put my new cluster in, struggling with that damn speedo cable the most, and viola it doesn't work either. Guess I should have checked that before I put it in...

Btw...if you have large hands, have some neosporin and some band-aids handy after you finish this job.
Reply With Quote
  #2  
Old 09-22-2002, 01:24 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
From this list I learned to disconnect the speedo cable at the trans which gives just enough cable travel to reattach it easily.
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page