Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-22-2002, 11:53 AM
Gregg Bambo Jr
Posts: n/a
Engine cutout/sputter above 4300 RPM

Engine cutout/sputter above 4300 RPM
All of a sudden my 220SEb cabriolet engine has gone from running like like a fine timepiece to missing/sputtering/cutting out whenever I am accelerating hard and after the RPM reaches 4300. It runs fine above 4300 if I am not accelerating. If I am cruising smoothly above 4300-5300 and punch the throttle, the problem will surface. It almost sounds like it starving and not getting enough fuel or air. I thought it might be a faulty advance but why would it run smoothly when not accelerating above 4300 if that was the case? Changing the fuel filter attached to the engine was no help and inspection of the old filter revealed it was in good condition. Is there an internal filter in the tank? I am assuming that the fuel pressure is ok if it can provide fuel to run at 5300 RPM. Any suggestions on what the problem could be? Thanks, Gregg
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page