Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-24-2002, 11:25 PM
Posts: n/a
Brake Problem

Greeting to all Benz owners, I am a second owner benzer myself. because of this site I have been able to bring a 83 300DT back to life. (I carted it home from Atlanta). After a few fixes she began to breathe again. So far it has benn running great. I noticed some pulling to the right while braking, so I checked all the way around,sure enough the brakes were worn sensors melted.I replaced the pads on the driver fornt. When I went to replace the passenger front only one side of the caliper would move. I did replace the pad on the side that did move. Next I purchased a caliper and put the other pad on. This is where the problem starts
I have noticed a srcubing sound sound from that tire I checked the install again but found no problem. It sounds like the caliper piston is slow to retract by the time I can inspect it the dang thing has righted itself. The brakes are no longer pulling to either side.

1. Am I dealing with a defectice caliper
2.Worn rotor
3.Collapsed brake line
Which seems to seems to be the likely culprit?
Am I missing something???

Thanks in advanced

245K and still ticking
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page