Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-30-2002, 03:16 AM
A. Rosich's Avatar
Registered User
 
Join Date: Nov 1999
Location: San Jose, Costa Rica
Posts: 883
Haunted Turn Signals

Suddenly, one morning, my E320T started an erratic operation on its turn signals. They would come on when engaged for a few seconds and then go dead. Same happens with the hazard lights.

Changed the fuse and check all bulbs to be on the safe side, but it did not solve the problem.

Sometimes when the I engage the turn signal and they are dead, when hitting a pothole on the road they will come on for a few seconds and then stop working again.

Any ideas or suggestions on what to look for???
Thanks in advance.

A. Rosich
S320, 1998
E320T, 1995
Reply With Quote
  #2  
Old 09-30-2002, 09:13 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
On the 1995 E320T there is a "combination" relay that controls this operation, MB part number 201-821-02-47.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 09-30-2002, 01:18 PM
A. Rosich's Avatar
Registered User
 
Join Date: Nov 1999
Location: San Jose, Costa Rica
Posts: 883
Thank you so much the advice!!!

I thought there ought to be a relay somewhere, but I wasn't sure.

That is why this site is so helpful!

Thanks again.

A. Rosich
S320, 1998
E320T, 1995
Reply With Quote
  #4  
Old 09-30-2002, 01:39 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
I just ordered this part from FastLane a few months ago. I don't know about yours, but in addition to blinkers & hazards, the relay on my C280 controls the rear defrost, and the intermittent wiper. It's nice to have all working again.

Part is cheap here too! $150 at the dealer, $50 on fastlane!
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page