Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 07-14-1999, 02:24 PM
Reed Smith
Posts: n/a
I have an 85 300SD Turbo Deisel. For some reason, sometimes when I hit a bump, tach and ac compressor go off. This may last for a few feet, or many miles, no matter how bumpy the ride, then they will both come back on. They are never on or off independently of one another. I have heard that the 84 & 85 models had some kind of "electronic control box." Any input? Thanks.
Old 07-14-1999, 08:08 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Whenever M.B. builds a car w/computer they include overvoltage protection. On your car the O/V relay is in the fuse box. It could be loose or going bad, check it out!
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page