Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-04-2002, 09:24 AM
Registered User
Join Date: Jul 2002
Location: Cleveland, OH
Posts: 22
124 Cruise Control

Using this forum - and other troubleshooting resources - I am still unable to get my cruise control to work. Here's where I'm at:

1989 260e. All the bulbs replaced with new ones straight from the local Mercedes Dealer.

I pulled the underside dash cover. With my multi-meter, I tested the switch. All looks good.

I checked continuity between amp plug and actuator plug. All looks good.

I checked acuator motor. The solenoid sounds good. The motor I'm not sure about. It draws about 170mA from 12v, both directions. I heard a slight whirring (with a tint of grinding) noise from its general vicinity- but didn't see any movement. Should I see the arm move on the acutaor? If so - then I know the actuator is bad (or jammed or stuck).

I resoldered amp and reinstalled. Got the cuise to work on first test drive (at about 41mph)- but after shutting the car down, then starting up again - the cruise didn't work. It has worked twice since (both at under 50mph). Seems to be on cooler days after it has sat for a while (12+ hours).

I have a hunch (or false lead?)- that the temeprature has something to do with it. Seems that a warm engine (or warm ambient) may be creating some sort of thermal expansion that seizes something mechanically or shorts something electrically. But that's just a guess. Any thoughts? Others experience?

Also, I didn't mess with the Hall Sensor. Anyone have repair or troubleshooting experience with it? How often do they go bad?
Reply With Quote
Old 10-04-2002, 10:52 AM
MikeTangas's Avatar
Senior Member
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
The actuator should only be drawing about 130mA, not sure how much effect 170mA draw would have on the operation.
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon least its a diesel

Non illegitemae carborundum.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page