Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-17-2002, 03:52 PM
Posts: n/a
'95 E420 - Are these all Motor Mount Part #'s?

When the transmission was replaced, the following mounts were also replaced:

(2) 124-240-26-17 Rubber Mount (motor mount?)
(1) 140-240-03-18 Rubber Mount (??? transmission mount ???)
(2) 107-492-00-82 Damping Pad (???)

I'm some vibration issues (see other posts) and I'm trying to figure what exactly has (or has not) been done.


Reply With Quote
Old 10-17-2002, 04:52 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
(2) 124-240-26-17 is the correct motor mount!
(1) 140-240-03-18 is the correct trans mount!
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 10-17-2002, 04:58 PM
Posts: n/a
Thank you very much. In reference to vibration post, now I can rule out the transmission mount.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:09 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page