Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-27-1999, 12:12 PM
Rick Miley's Avatar
Spark Free
 
Join Date: Jun 1999
Location: Tampa, FL
Posts: 3,086
Just returned from a 2 week vacation to find the battery dead in the 190E. This is a brand new MB battery. Tried to jump, but starter wouldn't engage. Recharged to full, but still no go. Lights are bright and don't dim at all when I turn the key to start. No noise either. Is there a relay or fuse I can check? Hate to tow it in for something simple. Thanks.

------------------
Rick Miley
Tampa, FL
99 E300DT
86 190E
87 300E

  #2  
Old 07-27-1999, 10:15 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
First put the car in neutral and try to turn it over. You may have to move the shifter back and forth a couple of times. After that you need a tech. Be sure to check the connections at the battery.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 07-27-1999, 10:15 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
First put the car in neutral and try to turn it over. You may have to move the shifter back and forth a couple of times. After that you need a tech. Be sure to check the connections at the battery.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
car won't start jude Tech Help 5 06-03-2004 12:24 PM
190 300sl---engine start problem--1990 fjones Tech Help 0 03-09-2004 07:08 PM
190 won't start Spacemann Tech Help 6 04-17-2002 08:53 PM
1991 420SEL - beginning of a cold start problem DieselGuy Tech Help 1 07-30-2001 04:56 AM
190 2.3-16 hard to start and keep idlng during hot start. Joe-1 Tech Help 6 06-04-2000 06:30 PM



All times are GMT -4. The time now is 10:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page