Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-20-2002, 05:02 PM
Registered User
Join Date: Mar 2001
Location: SF
Posts: 201
Unhappy Headlight Dimmer Madness! 86 300E

Hey folks, this is odd......My turnsignals work, washer/wiper function works, but the headlights are stuck on high beam, AND the low beams will come on as well, when selected! The blue Hi beam dash indicator is on all the time. Any thoughts other than pay $138.00 and spend the day installing it??? Gracias in advance!
Reply With Quote
Old 10-21-2002, 08:51 AM
Registered User
Join Date: Sep 2002
Location: Denmark
Posts: 412
Sounds a bit like a stuck relay..

What exactly would you pay $138 for??

Never criticize someone until you've walked a mile in his shoes. That way, when you do, you're a mile away -and you have his shoes!

'86 300E optically converted to '95 E300 (Sold)
-Blauschwarz on silver
-Black leather
-17" AMG & 15" AMG for winter
Reply With Quote
Old 10-21-2002, 11:56 PM
Registered User
Join Date: Mar 2001
Location: SF
Posts: 201
the combo switch

That is what you get for $138.00! This is really strange, I understand there are no relays in the system and the hi/low beam action seems normal..........
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page