Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-23-2002, 02:29 AM
Registered User
Join Date: Oct 2002
Posts: 30
Question Electrical Problem?

I posted earlier about a problem in which my warning indicators would come on (all of them) once the key is removed from the ignition. I was told that the alternator could be bad...I had an electrical shop do a test on the alternator with some sort of scanning tool and the alternator performed correctly.

I did a search on the topic and found an instance where someone had a similar problem and was told the ground strap to the engine was the problem. I pulled the skid plate and looked, the ground strap is right where it is supposed to be.

I am really confused. The problem also includes my glow plugs not working any more. There is also a small cylinder behind the passenger side headlight (it is directly under the air intake tube and has several vacuum lines attached to it) that seems to remain on unless the battery is unhooked.

If anybody has had a similar problem and could give me an idea as to how to repair this thing I would really appreciate it.

Thank you in adavance.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:03 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page