Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 08-01-1999, 12:10 AM
Registered User
Join Date: Apr 1999
Location: Toronto, ON, Canada
Posts: 113

I have a 1988 300E W124. Can someone please give me detailed instructions on how to replace the O2 sensor? Do I have to reset the engine management computer after replacing the sensor? If so, how do I do it? My car is a Canadian/US Federal version, so it doesn't have the push button/LED on the diagnostic panel next to the battery.

Thanks very much in advance.
Old 08-01-1999, 09:37 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The connector is located under the passenger side floor mat. It has two diferent connectors to unplug. One is the signal wire the other is the heater wires. You will need a 22mm wrench to complete the repair. It is advised to do this with the engine cold and the car in the air on a lift. You will have to have the Lambda rechecked after you finish.


Old 08-01-1999, 10:46 PM
Registered User
Join Date: Apr 1999
Location: Toronto, ON, Canada
Posts: 113
Thanks Benzmac....I've found the signal (1) and heater wires (2). However, it seems that the hole from the passenger sub-floor leading to the oxygen sensor is quite small...I don't think the heater wires (with the plug) will pass through the hole....

Also, is the other end of the wires directly connected to the oxygen sensor?

How do I check the Lambda?


[This message has been edited by E. Lee (edited 08-01-1999).]

[This message has been edited by E. Lee (edited 08-02-1999).]
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
FAIL Emission Test andrew1413 Tech Help 20 04-05-2004 04:07 PM
Oxygen Sensor Replacement '95 S320? sab Tech Help 11 07-07-2003 03:42 PM
Oxygen Sensor Output - Negative Value??? jgl1 Tech Help 4 09-12-2002 08:37 AM
C220 Oxygen sensor question chandrab Tech Help 0 01-12-2002 04:57 PM
560sl Oxygen Sensor santora4 Tech Help 0 01-07-2002 11:28 AM

All times are GMT -4. The time now is 04:25 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page