Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2002, 02:36 PM
Registered User
 
Join Date: Oct 2002
Posts: 23
Temperature display blank

My temperature display is blank. How can I fix this? Is it a bad sensor, bad display, or (my guess) loose/missing wire somewhere?

Ty
__________________
1994 E320 Coupe 56k
Reply With Quote
  #2  
Old 10-28-2002, 03:41 PM
sunil190e-1.8's Avatar
Registered User
 
Join Date: Jun 2002
Location: uk
Posts: 236
the temperature display bulb is faulty.

you will have to get the instrument cluster out-i gather this requires special tools to remove.

the bulb is not expensive but getting to it is the difficult part.
Reply With Quote
  #3  
Old 10-28-2002, 03:48 PM
Registered User
 
Join Date: Oct 2002
Posts: 23
Actually, the little LCD screen is lit up, just blank. It dims with the rest of the instrument panel. I found a connector on the passenger side under the hood behind the firewall with number 161937501 and the letters KB that has nothing connected to it. I thought that that may be the temperature sensor.

Ty
__________________
1994 E320 Coupe 56k
Reply With Quote
  #4  
Old 11-05-2002, 03:16 PM
Registered User
 
Join Date: Oct 2002
Location: Colorado Springs
Posts: 481
Question Temp display blank

Iam having the exact same problem. Display lights up and dims but read out is blank. I also could not find any information in the Service manuals about the external temp sensor either so I am stuck. Any Help appreciated.

Okay found a better thread Can anyone PLEASE help me fix my external temperature sensor?

Last edited by mhingram; 11-05-2002 at 04:33 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page