Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-03-1999, 08:41 PM
Nick Jamal
Guest
 
Posts: n/a
Always willing to get my hands dirty, I was rewiring the right taillamp cluster on my '86 300E. Stupidly, I left the key in the ignition, made a little spark and blew the fuse (#3). I replaced the fuse - but still no brake lights or dash control elements! However, the combination relay (201 821 00 47) has started buzzing whenever the car is on. Replacing the relay with one from my 300TE doesn't help - it buzzes too, and the 300E relay works fine in the 300TE. I can't go very long without brake lights so I'd really appreciate any feedback.

Thanks, as always, for everyone that makes this such a great site.
  #2  
Old 08-03-1999, 09:52 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You might have blown more than one fuse. I have seen fuses that are blown at the top or bottom or have a hairline fracture in them cause a similar problem.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 08-03-1999, 11:09 PM
Nick Jamal
Guest
 
Posts: n/a
Thanks Benzmac - fuse #5 had a hairline breakage. I could have saved myself a lot of time... but then, there would have been one less person to boost your ego today!

Thanks again.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn lights relay buzzing and NO RPM, oil pressure, coolant temperature displayed andrew1413 Tech Help 2 08-13-2004 04:53 PM
1986 300E Buzzing noise from relay box Mike Traquina Tech Help 2 09-24-2003 11:22 PM
Buzzing relay rsoennichsen Diesel Discussion 0 07-17-2003 09:34 PM
Buzzing Combination Relay Fintail Fan Tech Help 1 04-18-2003 08:41 PM
Dying, Fuel Relay buzzing, Tach wrong RPM. Stevegman Tech Help 4 04-22-2001 10:28 AM



All times are GMT -4. The time now is 06:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page