Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-31-2002, 10:14 AM
egils
Guest
 
Posts: n/a
Post Heating / defroster problem

I have two problems with my 86' 250D heater system:

1: The blower won't always start. I have to turn the ignition switch off and then on again to make it work. Poking with the fan speed switch won't work.

2: This car have individual temperature setting dials for passenger/driver. When starting the car (with hot or cold engine) the temperature in the car gets VERY hot, even if the dials are set low. I have to set the dials all the way down, to get cold air and the gradualy take the dials back up. After some time, it seems to stabilize at the temperature i want.

What could be wrong?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page