Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-05-2002, 02:18 AM
Registered User
Join Date: Sep 2000
Location: beaumont, texas
Posts: 226
can worn valve guide seals cause rough idle?

When i changed the spark plugs on my 300e, I found oil on them. I would suspect the valve guide seals need to be replaced. My car also seems to have a rough idle. I then put in fresh plugs and the idle improved. After several thousands of miles the rough idle returned. Could this be caused from the worn valve guide seals?
Reply With Quote
Old 11-05-2002, 08:32 PM
Senior Member
Join Date: Sep 2002
Location: New Jersey, U.S.A.
Posts: 2,398
Reply With Quote
Old 11-06-2002, 07:29 AM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
Oh yeah. Guide wear will foul plugs pretty guickly, especially if you combine that with a weak secondary ignition.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote
Old 11-06-2002, 08:01 AM
Posts: n/a
You betcha!

Have a great day,
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page