Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 08-08-1999, 02:02 AM
Join Date: Jun 1999
Location: Melbourne , Australia
Posts: 33
I cannot get the hood open on my W126. Ome side pops up but the other does not.
I have tried pulling the cable directly , but this still doesn't work.

Is there anyway to open the hood ??


Doug McCutchan
Old 08-08-1999, 09:31 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Have someone push on the side that is stuck while trying to open with the handle. Also a gentle strike on top of the latch location with the hand may work...Good luck


Old 08-09-1999, 12:40 AM
Robert W. Roe's Avatar
Registered User
Join Date: May 1999
Location: Lehigh Valley PA
Posts: 1,321
My '83 SD had this problem. There were three hood latches: the primary latch under the star in the middle of the hood, and two secondary latches , one on each side of the grille.

The passenger side latch was sticky and was harder to operate than the driver side. I had to wiggle the hood and push both hood latches together at the same time.

The fact that the hood is popping up indicates that the primary hood latch is opening fine. You need to push the secondary latch (the side that is sticking) toward the center of the hood while not letting the one on the other side relatch itself.

Once you get it open, take a look at the way it works. I'd lubricate all three latches, hinges, etc. Make sure you lubricate the hinged spring that pushes the latch back into its normal, outward, position.

Also take a look at the little black cylinders on the underside of the hood. I never fixed mine on my SD, but they move up and down; neither did I figure out what position they're supposed to be in, or if they are supposed to move at all... any ideas?

I'm haven't inspected my '84 to see if it's identical to my '83, but the hood latches work flawlessly. One you get good at getting a sticky one open, you can appreciate one that works fine

Robert W. Roe
1984 300SD 165K miles

[This message has been edited by Robert W. Roe (edited 08-09-1999).]
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hood release cable broke W123 Jacob Tech Help 1 10-02-2004 09:37 PM
Hood Release just won't make it GoWolfpack Vintage Mercedes 2 03-11-2004 04:05 PM
Hood release just wont make it GoWolfpack Tech Help 0 03-11-2004 12:48 PM
Seat Back Stuck W126 jonvee Tech Help 1 09-05-2003 02:36 AM
broken hood release and electrical problem 1stimer Diesel Discussion 2 03-27-2003 10:49 AM

All times are GMT -4. The time now is 07:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page