Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-06-2002, 11:37 PM
bandit1911
Guest
 
Posts: n/a
How to fix CLK 320 LAMP Defective warning ??

I have a 1998 CLK 320 and the Lamp defective warning is showing. I have checked all bulbs and none of them are out. Is there something I can do or check before I take it to the dealer??

Reply With Quote
  #2  
Old 11-07-2002, 09:53 AM
Registered User
 
Join Date: Dec 2000
Location: Northern New Jersey
Posts: 148
this also happened to me but , you need to check the lights more carefully. check the lic. plate bulbs and side marker lights. it s probably a bulb you are overlooking.
__________________
98 E430(sport), 99 ML 320 (sold) , 05 C 230(sport) Mark
Reply With Quote
  #3  
Old 03-24-2012, 03:01 PM
Registered User
 
Join Date: Mar 2012
Posts: 1
Quote:
Originally Posted by bandit1911 View Post
I have a 1998 CLK 320 and the Lamp defective warning is showing. I have checked all bulbs and none of them are out. Is there something I can do or check before I take it to the dealer??
Did you replace the bulbs with bulbs from a autozone or car store ? if so that is your problem. Mercedes are tempermental when it comes to bulbs it has to be the right ohm and rating go to the benz dealer and purchase new bulbs for about $50 you can get all the bulbs you need for the vehicle i promise once you replace them with the benz bulbs the warning would stop ..that happen to me this past weekend and that was the remedy
Reply With Quote
  #4  
Old 03-24-2012, 11:07 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
I agree that you might be overlooking a inop bulb. Be sure to also check the center stop light, the small side markers on the rear tail lights, and the clear front/center running lights. EDIT oh and the fog lights
Reply With Quote
  #5  
Old 03-25-2012, 01:11 AM
Registered User
 
Join Date: Jul 2005
Location: Seattle, WA
Posts: 591
i've found that the LAMP MALFUNCTION alert is quite reliable. so if someone
says they checked everything, they usually (still) missed a bulb. only exterior
bulbs are part of the monitoring system. for my 99 E320 they are:

(2) H6W dim bulbs inside the high beam reflector,
(2) front bumper side clearance bulbs,
(2) dual filament bulbs on the outside edge of the tails
(2) single filament bulbs on the inside edge of the outer tails

...then, when you step on the brake,
(2) second of the dual filaments light up on the outside edge of the tails
(1) light array in the high-third-Dole brake light near center back window

....don't neglect to eyeball,
(2) lights above the rear license plate
(2) lights when shifted into REVERSE
(1) rear fog light on left rear, when headlight rotary switch pulled 2 clicks
(2) front fog lights in front,when rotary switch pulled 1 click

....and natch,
(2) low beam
(2) high beam
__________________
-- raymond~
47 34'N 122 18'W
Reply With Quote
  #6  
Old 03-25-2012, 08:34 AM
RichardM98's Avatar
Registered User
 
Join Date: Oct 2007
Location: SoCal
Posts: 651
Also, on older models the bulb socket contact points get a little corroded and it changes the resistance. That's enough to trigger the error. The bulb will test OK but it's the socket. The sockets twist into place. Sometimes twisting all the way then rotating back slightly will provide a new contact point and all will be well.

You can do some tests to try to isolate the problem light. If the error appears when pressing the brake pedal it's one of the brake lights but won't go off until the engine is turned off. If it comes on when using the turn signals it's one of those. If it comes on when switching on the low beams... okay you get the idea.
__________________
Good luck.






1998 E320 Wagon

Last edited by RichardM98; 03-25-2012 at 11:36 AM.
Reply With Quote
  #7  
Old 03-25-2012, 08:53 AM
TX76513's Avatar
Platinum Member
 
Join Date: Apr 2003
Location: Brandon, Mississippi
Posts: 5,203
Going to add in one light failure that had me miffed - LED turn signals in the mirrors. If a few of the LED's fail it will cause the warning light to activate but light on mirror (appears) to be working until you take a close inspection.
__________________
BENZ THERE DONE THAThttp://www.peachparts.com/shopforum/...c/progress.gif
15 VW Passat TDI
00 E420
98 E300 DT
97 E420 Donor Car - NEED PARTS? PM ME!
97 S500
97 E300D
86 Holden Jackaroo Turbo D
86 300SDL
(o\|/o)
Reply With Quote
  #8  
Old 03-26-2012, 04:50 AM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
On this guys 98 he wouldn't have an LED third stoplight or any lights at all in the outside rearview mirrors.
Reply With Quote
  #9  
Old 03-26-2012, 12:11 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 3,046
The car in question has probably had three or four owners since the original post was made.
Reply With Quote
  #10  
Old 03-26-2012, 05:29 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Good catch

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page