Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-07-2002, 01:40 PM
Registered User
 
Join Date: Jul 2000
Location: Sunny Florida
Posts: 199
Economy gauge reading low when cold

My car is a 1989 560SEL, 148K miles. Since the cold weather hit Florida, (temps in the mid 60's in the morning), my economy gauge reads about 1/4 inch off the peg when idling, upon start up. Usually sits right on the peg. No other unusual symptoms, MAYBE a rough idle, if I listen really close. When the car warms up, the needle returns to normal behaviour.

I have not even cracked the hood yet to troubleshoot, but I plan to over the weekend. Any thoughts or ideas, where to look?

As always, I appreciate the help!!

P.S. Just installed new Pilots all around. SUCH a difference in ride from the Firestones.....
__________________
1989 560SEL (172k)
1989 325IC (122K)
2004 Suzuki Volusia LE (3500 miles)
2005 Yamaha Road Star (20 K miles)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page