Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-09-2002, 12:24 PM
Posts: n/a
Angry 380SL won't run in gear

Our 1981 380SL started smoking. We took it to the dealership and they removed the passenger side head. They then returned it to us with the head still off. A friend and I have put the engine back together, but it will not run when in gear. It runs well when in park. We are at wits end, any thoughts?
Reply With Quote
Old 11-09-2002, 09:45 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Can you rev it and make it run? Be sure that the wire to the distributor is on well and not cracked. I have also seen where the distribtor wasn't well grounded.

Also check the wires at the battery and make sure that all 3 are tight.
Donnie Drummonds
Reply With Quote
Old 11-10-2002, 12:35 AM
Registered User
Join Date: Dec 2000
Location: Battle Ground, WA
Posts: 576
cam timing?

Are you SURE that you got the cam timing correct? It could be that it's far enough off that it's able to run with no load, but doesn't have enough power to keep going in gear....
Just a thought...

Richard Wooldridge
'82 300D/4.3L V6
'94 Taurus (Wife's car)
'88 Astrovan
'77 Jag XJ6L
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page