Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-10-2002, 11:23 AM
Posts: n/a
300 E heater Quit!!!!

1989 399-E heater quit on me yesterday. None of the switches will turn anything on. Checked out all the fuses & the two in the relay section and are OK. Seems like an electrical problem. where do I go next. I would Estimate parts on heater motor or controls $250-300 plus installation. what should I check before giving up on this car?

Car also needs new water pump,tensioner,a/c compressor.
I'm ready to think about a change. Owned car for 4 years, rebuilt head last xmas but it runs ok. Too much for a rough car with 210K on it .

Reply With Quote
Old 11-10-2002, 04:02 PM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
My ventilation fan quit on our '91 300E about six months ago. I did the same checked fuses etc. I was dreading the fan motor replacement.

It turned out to be the fuse link. Its holder is about an inch long, about a 1/2 inch wide. It is an odd black plastic part near (in front of) the fuse box. It has two fairly heavy-duty wires going into it, one on each end.

Pry open the cover and inside you will see what looks like a flat piece of metal. These fail and will even look to be OK.

I might have a picture of its location if you can't find it.

'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Old 11-10-2002, 06:17 PM
pmizell's Avatar
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838

If your blower suddenly stopped, it's most likely one of the following:

- push button control unit
- blower motor regulator

Unfortunately both parts are quite expensive. Do a search on "blower motor" and you'll learn how to test the system to pinpoint the problem.

If you're lucky, it could be the fuse as haasman indicated.

Good luck
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote
Old 11-10-2002, 07:15 PM
Posts: n/a

haasman , that's for the info ,will check it out.

Paul how's the head job. holding up?
Reply With Quote
Old 11-10-2002, 07:52 PM
Join Date: Feb 2000
Location: seattle, wa
Posts: 87
try this.while the car is running wiggle your ignition key a little.alot of the time the ignition switch is loose and won't power up the blower. or check the bar fuse on the inner fenderwell mention in previous post.
Paul Roberts
Mercedes Centrum Inc.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page