Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-14-2002, 05:50 PM
ronbotwo
Guest
 
Posts: n/a
low speed lean mixture cis-e 500sl

Following rear chassis are fuel line leak my mechanic replaced both fuel filters in my 1990 500sl (119 dohc engine). Shortly thereafter the fuel pumps began making a noticable whining noise, whereas prior to the filter replacement they were quiet. Also prior to the filter replacement the engine was running rough under load for a period of time but then seemed to smooth out just prior to the filter replacement. After replacement of the filters and two new pumps the engine is again runnung very rough at low speed and backfiring throught the intact. It appears to be running lean. The mech indicated that the injection system had compensated for the low pressure from the defective pumps and now that new ones are installed it has somehow leaned itself out again. Any ideas? How do you adjust the mixture on a cis-e system?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page