Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-27-2002, 10:56 PM
Registered User
Join Date: Aug 2001
Location: Missouri Ozarks near MountainView MO
Posts: 107
79 450SLC Bad hot start problem--Solved

Thanks to those who gave advise regarding the saga of my very "cranky" hot start problem on this car. It turned out to be the Accumulator. In the process I also replaced the fuel pump, it was bad also. I also reset the timing, it was advanced by 26 degrees. I now have it set to max advance at 3100 rpm. Runs great but a little on the heavy side on gas usage, down to about 14 mpg.
Also had had a rock damage my radiator, I can not believe how small the radiator for these cars is. Its no wonder they tend to run hot. I almost had to park my 79 450 SL during the summer when I lived in Phoenix.
79 450 SLC
79 450 SL (sold)
88 Lincoln Town Car
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:20 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page