Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-25-1999, 05:51 PM
Albert
Guest
 
Posts: n/a
I have an 89 190E with the Becker stereo. Lately, it has been occasionally hanging up on inserting or ejecting a tape. Today, it would not eject the tape, but would also not stop running or allow the unit to be turned off. In trying to extract the tape, I got the "wheel" that turns the tape to stop turning (broke it it seems) and it turns off, but only when the car is turned off. The radio may or may not come on when the unit is on. Is there a way to get this tape out and at least a.)use the radio and b.)not worry about killing the battery?
  #2  
Old 08-25-1999, 11:15 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If the eject motor is bad, you will have to take the thing apart to take out the tape. We have replaced many of these little motors.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vacuum in Fuel Tank and common intermittent problem on 1992 190e 2.0 webcentre Tech Help 18 08-31-2005 06:23 PM
190E running rich problem AGAIN after repair!!!HELP!!! azhari Tech Help 35 12-30-2003 01:30 PM
1992 300SE Tape Deck Problem kenshainker Car Audio and Multimedia 2 07-21-2003 11:59 AM
190e 16v problem ??? daveCT Tech Help 30 06-20-2003 12:47 PM
Intake Problem on 190E pistolpete5113 Tech Help 0 01-05-2003 02:38 AM



All times are GMT -4. The time now is 02:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page