Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-06-2002, 02:43 PM
Registered User
Join Date: Dec 2000
Location: South Jersey
Posts: 7
85 190D2.2 Starting Problem

I have an 85 190D 2.2, 147K Sometimes it starts and sometimes not. It started in 20 degree weather an 1 hour later would not start. Glow plug light goes out normally. Can't figure out why it starts sometimes. Weather does not seem to be a factor.
When I use starting fluid it starts right up. I've changed the fuel filter. I think it does happen more when the tank is below half but I'm not sure this is a factor either. Where should I look.
Thanks, Dan
South Jersey
Reply With Quote
Old 12-06-2002, 05:47 PM
Piotr's Avatar
Registered User
Join Date: Jul 2002
Location: Middletown, DE
Posts: 739
check your fuel pump and glow plugs. if the fuel level is the suspect,I'd bet on fuel pump
1985 190D 2.2l Sold-to Brother-in-law
1996 Mustang 3.8l -"thinks it's a sports car"
1988 Grand Wagoneer - Sold (good home)
1995 Grand Cherokee Ltd -"What was I thinking??!!"
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:17 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page