Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 09-01-1999, 06:39 PM
Registered User
Join Date: Aug 1999
Location: St. Louis Mo
Posts: 18
As I may have said before, the 190 failed it's emission test untill the mechanic leaned out the adjustment on the fuel distributor. After the car didn't run well and so they set it back in the richer position. Said that may be what they would have to do. It failed with high unburned hydrocarbons. It was suggested to me that was probably due to some ignition failure. I have replaced the spark wires, cap and rotor and checked the gap and condition on the plugs. They only have about 5 to 7 thousand miles on them. I am now asking what else might be the cause. I am getting about 22mpg on highway and 15 in town. I used to get 25 and 20.
do you have suggestions as to what next to try? Should I take it to a dealer as ask them to do...what?

Thanks for your excellent service and parts.
John Lee
Old 09-01-1999, 08:34 PM
Chris C.
Posts: n/a
Anyone bother to find out why? is the O2 sensor any good? Temp. senors, fuel pressures, etc. I know it's after the fact but think about it... why would you have to adjust the fuel mixture? Unless someone messed w/ it before? It should not change correct? Now when you find the problem the fuel mixture will have to be readjusted. I would suggest starting w/ most common reason which is the O2 sensor on high milage cars.
Hydrocarbons is unburned gas, either an ignition miss or the mixture is to lean from adjustment, vaccum leak, incorrect mixture inputs from sensors, bad valve(s).
So your kind of all over the place, so it might be worth it too you to find a good Bosch injection mechanic, the KE system is really not that diffucult to troubleshoot for a good mechanic. Besides if your running lean your really hurting the motor.
Not much help, sorry,
Chris C.
Old 09-02-1999, 07:03 PM
Registered User
Join Date: Mar 1999
Location: southern pines NC
Posts: 35
Your gas milage seems rather low. I have a 92 190E2.6 with 80K miles and it gets 27-29 mpg on the highway and about 22-24 around town. I set my CIS a little rich (1 flat on the 3mm adjustment screw) which helped with cold start and running. The EHA current during closed loop changed from -1.5 ma to about -3.0ma. I changed my O2 sensor at 50K due to surging at idle and the result was a faster O2 response and a little leaner EHA reading. I used an O2 sensor for a 5.0 Mustang for $39.00 and just cut the wires and soldered the wire ends from my old O2 sensor. Works great and very easy to change.
Old 09-03-1999, 10:17 AM
Registered User
Join Date: Aug 1999
Location: St. Louis Mo
Posts: 18
Is the CIS adjustment the one that is at the bottom of the hole through the Air Cleaner. Located on the fuel distributor?

Which way to turn for lean, rich?

Use a 3mm hex?

Thanks, John
Old 09-03-1999, 08:33 PM
Registered User
Join Date: Mar 1999
Location: southern pines NC
Posts: 35
Yes, The adjustment is the hole in the air cleaner housing with the rubber gromet. It is a 3mm screw and you need to see if the tamper plug(ball bearing) has been removed. Once access to the 3mm screw is obtained, while the car is at idle, push down on the adjustment screw and turn until it engages into the screw attached to the sensor plate. The adjustment is very sensitive and only about one flat (1/6 turn) of the hex wrench is needed. If you can measure EHA current at the same time, you can get an idea of your adjustments. Clockwise makes it richer. The Bosch Fuel Injection & Engine Management book byb Charles Probst is very good and easily available at book stores and /or auto parts places. If you have the MB engine manual, it has the procedure also.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
failed emissions - suggestions? jsmith Tech Help 7 09-27-2003 08:10 PM
FS: 190 2.6 Eibach Springs MRPerformance Mercedes Used Parts For Sale & Wanted 7 06-23-2003 04:48 PM
190 2.6 for sale hemphog Mercedes Cars For Sale 0 08-11-2002 10:37 PM
190 e. 2.6 emissions fail Jnolee Tech Help 2 08-19-1999 09:56 PM
1989 190 E 2.6 Emissions jnolee Tech Help 1 05-23-1999 07:16 PM

All times are GMT -4. The time now is 10:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page