Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-10-2002, 09:26 AM
Registered User
 
Join Date: Jul 2001
Location: Motor City. MI
Posts: 73
w107 grounding problem

gauges go crazy when turn signals are applied. have inst. cluster out but need wiring diagram or guidance to isolate which pin, etc. is ground. ..for example:.. each guage has a brass stud fixing it to cluster. assume this is not a live connector. guage also has brass rivets coming through circuit board. continuity check between these 2 is live. any ideas short of $380. for new guage cluster?
Reply With Quote
  #2  
Old 12-10-2002, 04:02 PM
Registered User
 
Join Date: Jan 2002
Location: Niceville, FL
Posts: 471
Going from memory here, but I believe there is a central ground on the firewall behind the instrument cluster. Believe there is another on the passenger front sidewall by the OVP relay. One more I think, but don't recall where.

Also, I have an instrument cluster I bought off eBay that I can part with reasonably if you must have one.
__________________
Don
'85 500SL (Euro) - 186,000 w/a complete restoration and engine rebuild at 154,000
'95 C280 - 174,000
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page