Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-10-2002, 04:16 PM
Registered User
Join Date: May 2001
Posts: 54
E320 Rear Window Defrost Not Working HELP!!

My 97 E320 Rear Window Defrost doesn't defrost, the button lights up on the dash, but the rear window stays fogged up, any ideas or suggestions?
Reply With Quote
Old 12-10-2002, 04:19 PM
Registered User
Join Date: Apr 2002
Location: Surrey, Uk
Posts: 254
Check the fuse.

Get a voltmeter and check for power and ground continuity at the connections onto the window element. Most likely you're looking for a broken wire near the tailgate hinge position.
Mick J
'08 Chrysler 300CRD (MB OM 642 engine)
'95 E220 estate
'89 230TE (R.I.P.)
Reply With Quote
Old 12-10-2002, 04:22 PM
Registered User
Join Date: May 2001
Posts: 54

Where is the wire for the rear window, is it in the trunk, or underneath the panel inside the vehicle?

Reply With Quote
Old 12-10-2002, 04:22 PM


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page