Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-11-2002, 10:34 PM
Registered User
 
Join Date: Apr 2002
Posts: 15
1995 C220 electric problems

My 1995 C220 engine starts and than stops immediately. It's still running only if I keep my foot on gas pedal. The fuse #23 in fuse box under the hood is blown. This fuse has marking "engine components" or something similar. I changed the fuse, try to start the engine and the fuse was blown again. Another thing, when the engine was idling, there was a kind of vacuum cleaner noise coming from the engine, and it lasted for couple of minutes. There is no noise anymore. Does anyone know what's the problem and what is connected to fuse #23. I just bought this car, it was running perfect, this problem started all of a sudden.
Thanks
Reply With Quote
  #2  
Old 12-11-2002, 11:48 PM
Registered User
 
Join Date: Apr 2000
Location: San Antonio, TX
Posts: 387
You'll get this comment from many:

Have you had the wiring harness checked? Do a search on it, you'll see instructions on how to check it or have it checked.
__________________
Bill Streep
San Antonio
'57 190SL (toy)
'08 S5500 (mine)
'09 CLK550 (wife's)
'06 SLK350 (daughter's)
'11 GLK350 (daughter's)
'03 CLK310 (spare)
Reply With Quote
  #3  
Old 12-11-2002, 11:48 PM
Senior Member
 
Join Date: Apr 2001
Location: Baton Rouge
Posts: 485
According to my woring diagram fuse 23 has the following on it,
front dome lamp with switch- off delay and reading lamp (e15/2) ATA control module (n/26) Infrared remote central locking control module ( n/54) Dimmable interior rear view mirror. Now for the noise under the hood sounds like a loud air pump from what you say.
__________________
euro 287
Mercedes Technician 7 Years (retired to Hyundai)
2000 Dodge Durango
98 Mazda truck
Reply With Quote
  #4  
Old 12-11-2002, 11:51 PM
Senior Member
 
Join Date: Apr 2001
Location: Baton Rouge
Posts: 485
The c-220 for that year have bad engine harness' , throttle valve harness' as well as transmission harness' that go bad. You may have more than one problem here though.
__________________
euro 287
Mercedes Technician 7 Years (retired to Hyundai)
2000 Dodge Durango
98 Mazda truck
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page