Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-12-2002, 01:40 AM
Registered User
Join Date: Mar 2000
Posts: 517
'91 500 SL ACC Pushbutton Control Unit

'91 500 SL, 61K miles - ACC PBC unit occasionally is unresponsive at engine startup - none of the buttons function and climate control fails to engage in any mode. Restarting the engine makes no difference. However, several hours later the unit again becomes functional. When queried the unit states no fault codes are present and will display current sensor valves. Blower motor and regulator are new and all ceramic and strip fuses have been replaced. Dealer states these early units were troublesome and have been replaced by a new style.

Is this symptomatic of a failing PBC unit?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page