Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-07-1999, 04:07 PM
daniel
Guest
 
Posts: n/a
Just wondered if you had any idea on what to look at for a rough idle? When you first start the car when cold it seems fine, but after it warms up usually need to pump the excelerator peddle to get it started?
  #2  
Old 09-07-1999, 05:37 PM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935

This is a hot start problem. Somewhat unusual with the CIS systems, but in this case, you are probably looking at a new enrichment compensator. They are usually about $375. While you're at it, you might as well replace the injectors as well. I think they're about $28/each from MB. Hope this helps. Oh, by the way, make absolutely sure you are running the highest octane fuel available, preferably Shell 93 or Sunoco Ultra 94.


------------------
Rgds,
Aaron Greenberg
MB technician
'67 250SE Cabriolet
'77 450SL
'79 6.9
'79 6.9
'80 300SD
'81 240D
'85 380SE
'89 420SEL
'93 300E 2.8
  #3  
Old 09-09-1999, 07:02 PM
Abe
Guest
 
Posts: n/a
I had this same problem with a 1974 450SE. There is a cold start enrichment valve which is probably remaining open after the motor heats up - thereby continuing with an overly rich mixture which fouls the plugs. Check the plugs - if they are gas fouled it may be your problem. The valve was cheap and easy to replace.

------------------
Abe
1970 280SL
1974 450SE
1998 E430
2000 E55
  #4  
Old 09-09-1999, 10:26 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The 74 and the 78 have different fuel managment systems!! I agree with Aaron on the warm up compensator.
After you check it we can get you one.
We can ship them anywhere via partsshop.

------------------
Benzmac:
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM

  #5  
Old 09-09-1999, 10:46 PM
Junior Member
 
Join Date: Sep 1999
Location: right coast
Posts: 5
Sometimes I get the older cars mixed up but isnt the 78 450 SEL ( 116 chassis), an Electronic injection system, therefore it does not have an enrichment compensator. The enrichment comp. is only used on CIS cars.
I believe CIS was introduced in 84 on the 201 chassis with a 102 or 103 engine.
Now on the 78, if it is electronic injection, enrichment is done through Injector open duration via the engine control computer.
The first thing I would check is to check fuel pressure at rest and make sure its not leaking ( either an injector or the regulator).
hope this helps!!!
  #6  
Old 09-10-1999, 01:31 AM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935

CIS was used on '76 and later V8s, including the M-100 (450SEL 6.9). Cars pre-'76 suffer from vapor lock problems. Not fun to deal with and a major pain in the butt! This injection on the early cars was known as D-Jetronic, and on '76 and later was K-Jet. And in 1980, the final year, came K-Jet with Lambda. Finally, the continuous injection systems (CIS) were as follows: K-Jet, K-Jet with Lambda, KE-Jet, and KE-Motronic. So Justin, I believe you are wrong in your thinking. Hope I have clarified this.

------------------
Rgds,
Aaron Greenberg
MB technician
'67 250SE Cabriolet
'77 450SL
'79 6.9
'79 6.9
'80 300SD
'81 240D
'85 380SE
'89 420SEL
'93 300E 2.8
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle and hard start dalba Diesel Discussion 5 01-03-2005 10:41 PM
Had rough idle, now hard cold start mb82 Tech Help 4 06-26-2004 08:38 PM
190E 2.6 - rough idle when cold + hard start when warm + ABS light on johnqle Tech Help 3 02-05-2004 09:48 PM
M103 hard start, rough idle, hesitation SOLVED tryan Tech Help 9 02-12-2003 06:00 PM
560SEL hard start /low rough idle algae1 Tech Help 0 05-30-2002 10:49 AM



All times are GMT -4. The time now is 09:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page