Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-15-2002, 04:59 PM
Registered User
 
Join Date: Feb 2002
Location: Indianapolis
Posts: 51
Unhappy Oil smelled like gas

I changed oil on my 93 300E today and as the oil came out of the engine there was a strong smell of gas.

Afterwards I smalled the oil and it also smelled like gas too.

Any suggestions.
Reply With Quote
  #2  
Old 12-15-2002, 05:47 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Some questions for you:

- How many miles on your car?

- What are your typical driving habits? That is, do you often drive less than a few miles, to work, to the store etc.

- How many miles between oil changes?

- How is your MPG?

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #3  
Old 12-15-2002, 08:51 PM
Registered User
 
Join Date: Feb 2002
Location: Indianapolis
Posts: 51
Car has 170K miles on it. The gas consumption is very good about 26 miles per gallon. I drive about 100 miles a day and it is mostly highway.

I changed the oil after about five thousand miles. Last time when I changed the oil it was fine.
Reply With Quote
  #4  
Old 12-16-2002, 12:07 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Hmm all of that sounds right. How about the after next time you drive it so it gets to full operating temps for over 20 or so minutes, wait till its cool again and check the smell of the oil off the dipstick before starting it.

A lot of cold (rich) starts in cold weather definitely contribute to gaseous oil.

From what you said, it doesn't seem to be using a lot of fuel....

How does it start warm? Hot?
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #5  
Old 12-16-2002, 03:42 PM
sread
Guest
 
Posts: n/a
oil smells like gas

Did you notice any increase in oil level? Did engine run OK? (bad injector)
Reply With Quote
  #6  
Old 12-16-2002, 07:04 PM
Registered User
 
Join Date: Feb 2002
Location: Indianapolis
Posts: 51
Sometimes there is a little vibration in the engine at idle I can feel it in the steering. Other wise the car runs good.

There is also a small oil leak from the front of the engine. I replace the timing chain cover seal a while ago, but it started to leak again.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page