Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-17-2002, 04:43 PM
Posts: n/a
S600 Heater problem

I have a 92 S600 which has a heater problem. There does not seem to be any hot air coming from the under-dash vents. If I rotate the temp wheels to max hot, the heater fan speads up and the air gets hotter, but no air from lower vents. Now if I turn the temp wheels to max cold, the lower vents open, and hot air is directed to the footwells, intitally hot, till the air con takes over and cools it.
My question. What is stoping the footwell flaps from opening, and why do they open when cold is selected.

btw the engine temp is as it should be.

Many thanks for any helpfull advise.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page