Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-23-2002, 10:24 AM
Registered User
 
Join Date: Dec 2000
Location: Mountain Island Lake, Charlotte NC
Posts: 376
560sl odometer and speedometer not working

Hey everyone..my odometer and speedomter stopped working this morning..just out of the blue stopped working. Any ideas of what is causing this? I hope to gosh that they don't have to go into the dash board..I understand that can be very expensive.

Any thoughts?

Happy Holidays from Charlotte
__________________
Rob Armstrong, Charlotte, NC
Mountain Island Lake
RobAinCLTNC@hotmail.com

2004 VW Passat GLS TDI-50k
2006 Honda Odyssey EX-L 7k
FOR SALE 1991 300TE 228k

2003 Subaru Outback 57k Silver/Black-SOLD
2005 C230K 18k Pewter/Grey-SOLD
1997 E420 108k Black/Grey-SOLD
1986 560sl 200k Black/Palimino-SOLD
1985 300sd 340k-SOLD
1979 240d 170k-SOLD
2000 Volvo V70XC-POS couldn't sell fast enough
Reply With Quote
  #2  
Old 12-23-2002, 12:01 PM
Registered User
 
Join Date: Apr 2002
Posts: 139
it's fairly easy to push the instument cluster out from behind. unscrew the speedo drive to make sure it still spins. it might be the cable.

(if you remove the cluster, don't start the car. you will be covered in oil.)

if the cable spins, your problem is in the speedometer itself.

on some older mechanical vdo's, the 10ths wheel gets stripped from the shaft. if you are confident, you can dismember the speedometer and force fit the 10ths wheel back on with piece of waxed thread ( had worked three times in three different cars )

do not reset the trip meter while moving. that is what strips it from the shaft.
__________________
g-wagen
Reply With Quote
  #3  
Old 04-01-2008, 02:34 PM
Registered User
 
Join Date: Mar 2008
Posts: 4
Important to remember for new owners

Tryan
Too funny your last comment hits it on the head. Don't wonder if it is broken or not just ask the question: Did you reset it while you were moving? I did on Friday right after I bought the car. Thanks for the information. Good thing I live in Norfolk VA which is just across the river from Odometer gears http://www.odometergears.com/mercedes.html.

Thanks again
Pat
Reply With Quote
  #4  
Old 04-03-2008, 03:34 PM
Super Moderator
 
Join Date: Apr 2000
Location: Falls Church, VA
Posts: 5,314
Suggest you ignore the above advice about the cable spinning. Your 560 has an electric speedo.

I am having the same trouble with my 380. Here is the best post on the topic:

No speedometer!?
__________________
Chuck Taylor
Falls Church VA
'66 200, '66 230SL, '96 SL500. Sold: '81 380SL, '86 300E, '72 250C, '95 C220, 3 '84 280SL's '90 420SEL, '72 280SE, '73 280C, '78 280SE, '70 280SL, '77 450SL, '85 380SL, '87 560SL, '85 380SL, '72 350SL, '96 S500 Coupe
Reply With Quote
  #5  
Old 04-16-2008, 12:24 PM
Registered User
 
Join Date: Mar 2008
Posts: 4
Odometer issues

Thanks for the comment ctaylor738. There might be some clarification needed on this. My speedometer works fine just my odometer not working. My odometer is 100% mechanical so something turns it and that points to broken little gears inside the instrument so I shall investigate in that direction. Thanks
Pat
__________________
Cruising is a way of life not an attitude
Reply With Quote
  #6  
Old 04-17-2008, 09:53 AM
MB, love..hate..love..
 
Join Date: Apr 2003
Location: NB Canada
Posts: 1,173
Quote:
Originally Posted by gtmopat1 View Post
Thanks for the comment ctaylor738. There might be some clarification needed on this. My speedometer works fine just my odometer not working. My odometer is 100% mechanical so something turns it and that points to broken little gears inside the instrument so I shall investigate in that direction. Thanks
Pat
This might help both you and the OP Odometer Repair VDO Electronic version
__________________
1986 560SL
2002 Toyota Camry
1993 Lexus
Reply With Quote
  #7  
Old 04-18-2008, 08:47 AM
Super Moderator
 
Join Date: Apr 2000
Location: Falls Church, VA
Posts: 5,314
If you look on ebay under "mercedes speedometer," you'll find a guy named Jason in Phoenix who fixes them. His email is jschoenfeld at coxdotnet. He fixed mine. What usually happens, he said, is that either the gears get a small chip and get stuck, or the gears lose their adhesion to the rod that threads through them.
__________________
Chuck Taylor
Falls Church VA
'66 200, '66 230SL, '96 SL500. Sold: '81 380SL, '86 300E, '72 250C, '95 C220, 3 '84 280SL's '90 420SEL, '72 280SE, '73 280C, '78 280SE, '70 280SL, '77 450SL, '85 380SL, '87 560SL, '85 380SL, '72 350SL, '96 S500 Coupe
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page