Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-24-2002, 07:23 PM
Registered User
 
Join Date: Jun 2002
Location: Oakdale, CA
Posts: 28
Wiper motor or switch?

A bit of a problem with my 93 300E 2.8's monoblade. I am not sure whether it is a motor or switch problem. The wiper goes through the entire correct path when on, but comes to rest approxiametly 1/3 the way up my windshield. I am not sure if it is the switch not turning off to the right point, the motor not turning off to the retract point, or the mechanics all gummed up and need ing greasing i.e. the previous post I did that came up with a way to remove and grease the assembly. Any suggestions before I go buy silicone grease and risk messing something up during the rainy season?
Thanks and Merry Christmas to all!
Brooke
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page