Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-28-2002, 04:16 PM
Posts: n/a
Question oil pressure

I am the new owner of a 1993 190e 2.6. When I start the engine from cold, the oil pressure takes a couple of seconds before it starts to rise. During this period of time, I can hear tapping noises. Once the pressure begins to rise, the engine is very quiet. The pump seems to be working well as the presure is good and remains good during all driving situations. I have just changed the oil with 15W-40 oil & a new MB dealer obtained filter. The noise that I hear is simalar to the noise that one hears after changing the oil the happens until the oil filter is filled. I suspected that the car had the wrong filter until I changed it & found that the old filter was a MB filter also. Does anyone have any experiance with this situation? Is there a check valve that is not functioning?
Reply With Quote
Old 12-28-2002, 04:45 PM
blackmercedes's Avatar
Just a guy
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
Our 1990 190E 2.6 has done that for years and over 200K. Seems to have no ill effect. Something is probably amiss, but I haven't fixed it, and probably never will.
John Shellenberg
1998 C230 "Black Betty" 240K

Reply With Quote
Old 12-28-2002, 07:03 PM
sunil190e-1.8's Avatar
Registered User
Join Date: Jun 2002
Location: uk
Posts: 236

my car, a 190e-1.8 litre-1993-uk spec ,does the same thing on initial startup from cold-it was more noticeable when i had 15w/40 oil,then i switched to a thinner 10w/40 semi synthetic oil.
the noise is still there but less pronounced,i would agree with black mercedes that it's probably normal wear and tear for my car has covered 112,000 miles.
i have just learned to live with it-if it aint broken,then no need to fix it.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page