Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-30-2002, 04:27 PM
Registered User
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
Need help with fuel pump relay wireing

The car is 1985 190E 2.3

and as I was suspecting the fuel pump has been jumped so that the car runs, however, the fuel pump relay is knocked out of the equaytion and I would like to put it back together now that I found the problem.

My problem is with the wires coming from the fuel pump relay to the electrical centre and to the fuel pump.

I have the wireing diagrams, but I'm missing a wire, which I need to fix this.

Here is the setup. The electrical center is on the driver side, the fuel pump relay is on the passanger side.

Under the electrical center, there was a jumped wire, to the fuel pump, with another wire from the electrical centre, which is for something, I'm not sure what yet, but it's not important.
Now the fuel pump wire is supposed to plug into something, but I can't find that something. It has a female connector on the end, but the male is nowhere is sight.

According to the diagram, it is supposed to be plugged into the same kind of a wire, but it is supposed to go through the electrical centre, to be fused I guess. There is no fuse in the current combination, no rev limiter, no pump shut off either because of this, as soon as igition is turned on, the pump goes on and stays on as long as the ignition remains on.

I need to find out what happened to the wire, or where I can find it, that the fuel pump is supposed to be plugged into. I know this is a very common fix for faulty fuel pump relays, but normally the pump is jumped right at the fuel pump relay, I was not this fortunate.

I will be getting a new fuel pump relay, and would like to know how to hook up the wires to restore everything to factory settings.

Thanx in advance for any help.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:43 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page