Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-04-2003, 05:59 PM
Michael B
Guest
 
Posts: n/a
260e Cruise Control Gets Faster and Faster!!!

Help!! When using the cruise control on my '88 260e... it won't hold a constant speed. It keeps getting faster and faster... and faster!! I'm afraid to see just how fast she'll go... but I need to fix this situation quickly.

Any idea? I've searched the archives and found lots of postings for cruise controls that stopped working. But mine works... it just keeps giving the car more gas for more speed.

Thanks!!
Mike
Reply With Quote
  #2  
Old 01-04-2003, 08:18 PM
bjcsc's Avatar
Registered User
 
Join Date: Nov 2002
Location: Charleston, SC
Posts: 672
Mike:
Check the switch. I do not know if your cruise switch is like mine, but if it is, then it will set when moved up or down. Try to set it by moving it down and see what happens. Your switch might be getting stuck and thus remains in 'accel' when you set it 'up'. If you set it 'down' it shouldn't happen if this is the case. If your switch is different and none of this applies, contact Peter at GDL and find out how to test the switch. If you get lucky it will be the problem.
__________________
1982 Mercedes-Benz 300CD
1982 Mercedes-Benz 240D - stick
Reply With Quote
  #3  
Old 01-04-2003, 08:29 PM
Registered User
 
Join Date: Jul 2001
Location: Fla
Posts: 122
same thing happens to my 89. dont worry, it doesnt go higher forever! it goes up 5mph. dont ask me why it does it. sometimes it does it for me, sometimes it doesnt. i know its broken, i just dont know how to fix it.
__________________
1989 260E
- 300E engine
1998 C230
1995 E320
Reply With Quote
  #4  
Old 01-04-2003, 09:11 PM
Jackd
Guest
 
Posts: n/a
I would suggest you start by making sure the throttle linkage joints are clean and well libricated.
I had cruise control problems on my car solved by a simple cleaning/lubricating of the linkage.
JackD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page