Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-06-2003, 10:42 PM
Posts: n/a
300sl engine sputter fixed

i just fixed my 300sl hot start engine sputter. ive owned the car for eight months and have always had a hot and warm start sputter and sometimes stall. two mechanics could not fix the problem. i finally after reading all of the threads decided to replace the fuel injectors. it was pretty easy job(with the exception of one) not very expensive too. the car runs great. thanks for all of the advice
Reply With Quote
Old 01-06-2003, 10:58 PM
G-Benz's Avatar
Razorback Soccer Dad
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Congratulations...and thanks for sharing!

More often than none, folks will post a thread about their particular vehicle anomaly, and many will respond with their expert advice or helpful observations. But we never find out about the outcome (successful or not).

So it's always refreshing to read how this forum is helping many with solving knotty MB problems.
2009 ML350 (84K) - Family vehicle
2001 CLK430 Cabriolet (71K) - Wife's car
2005 BMW 645CI (124K) - My daily driver
2012 Mustang V6 (60K) - Daughter's car
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page