Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-11-2003, 05:53 PM
Posts: n/a
Unhappy Emission system troubles

I sure hope someone can help me. I just aquired a '69 230 and everything about the engine looks pretty good, runs really rough though. I did notice that the last owner had removed all the emissions stuff and sank bolts into the cylinder head where the hook-ups were. My question is this; would the car run any different with that stuff gone? Is it harder to tune with it gone? There doesn't seem like any leaks are around the bolts into the cylinder head, but it runs with a little miss and I've replaced all the ignition equiptment and set the dwell exactly. It would seem stupid to go looking around for this smog stuff to put it back on unless the car it going to run better with it on.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page