Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-17-2003, 11:53 PM
Posts: n/a
strange sound

My Dad gave me his old car to use. It runs great. Only problem is there is sometimes a groan in the front when making a sharp and slow turn. I can also feel a vibration in the steering wheel when it makes this noise. Does something need to be lubricated?

Thanks for reading this. Nice board!
Reply With Quote
Old 01-18-2003, 01:48 AM
Registered User
Join Date: May 2001
Posts: 108
Try replacing the power steering fluid. The easy way is to scoop or suck out the old fluid with a turkey baster. Put the clean stuff in then drive the car and do it all again a couple of times. I use prestone power steering fluid. Works great.
Reply With Quote
Old 01-18-2003, 04:16 AM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
also check the belt tension. If the power steering pump hasn't had its filter replaced recently, thats a good thing to do as well. They are not very expensive.
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page