Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-18-2003, 04:42 PM
86190e2.3
Guest
 
Posts: n/a
86 190 e 2.3 intermittent loss of power...etc

I have a 86 190e 2.3. I replaced the coil, fuel pump, filter, relay and pressure regulator. I was having problems with the car loosing power and stalling. After replacing all of the above parts it ran fine for about 75-100 miles. The next day I get about 6-7 miles and it acts like it looses power on a cylinder or two......then a few miles down the road it is back to normal. I took the fuel pump relay out and hot wired the pump.....it would do the same thing off and on. But if i pulled the jumper wire and plugged it back in it would do fine for a few miles and then the same old story. Are there any relays etc...that are problems on this model. Any help with this would be appreciated......

Thanks
Reply With Quote
  #2  
Old 01-18-2003, 08:22 PM
Registered User
 
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
A bad spark plug wires perhaps?

just thought I would mention it since I got a new set less then a month ago and two out of the four already fell apart, piece of crap...

xp
Reply With Quote
  #3  
Old 01-19-2003, 05:07 AM
Registered User
 
Join Date: Jan 2003
Location: Benz World
Posts: 2
Sounds like similar problem as Babybenz. Try askin him.
Reply With Quote
  #4  
Old 01-19-2003, 09:41 AM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
You have done spark plugs and wires, right?

What you're describing doesn't sound like a fuel-related problem (power loss on 1 or 2 cylinders)
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page