Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-07-1999, 10:16 PM
Blakforst1
Guest
 
Posts: n/a
I have replaced head gasket, and completed valvejob. The car is still pumping alot of oil in coolant.
I traced the problem to the intergrated oil cooler in the oil filter housing. I hve discovered that it has been updated several times. You will have to replace a coolant pipe and fitting, along with oil filter housing with oil cooler.

TG3@blackforest
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
oil in coolant benz350sdl Diesel Discussion 12 12-09-2003 01:10 AM
300SE Oil Consumption TClanton Tech Help 5 07-30-2003 01:56 AM
Any fanatics religiously change oil @ 2.5K intervals or less? -fad Tech Help 60 03-19-2002 12:22 PM
Motor Flush drew3395 Diesel Discussion 39 01-12-2002 04:22 PM
Oil 1989 300se Oliverp Tech Help 4 08-24-2000 01:57 PM



All times are GMT -4. The time now is 05:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page