Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-31-2003, 05:59 PM
Posts: n/a
Unhappy 107 heater problems

having heater problems 82 380sl.
tested blower with 12 volts ,at outside terminal blower works all stages.
replaced climate control unit & heater regulator.
only get blower working if i wiggle the harness on the left side of the unit. opened harnesses and all solder joints looked ok.
when working do get heat so i think temp regulator is ok
do the wire harness deteriate and short out.
should i replace wire harnesses for heater units where do you get them?
is there a part missing that controls the blower motor that i am missing and don't know about. there does not seem to be any on the schematic
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page