Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-01-2003, 08:10 PM
Registered User
 
Join Date: Dec 2002
Posts: 8
Unhappy Glow Plug Indicator

Hi:
I have an 85 300 SD, and i've noticed that my glow plug indicator on my dash is no longer lit when i try to start my car. As a result , the car is now a little harder to start. any help as to how to rectify or repair this would be appreciated.

my email tcumb@yahoo.com

thanx in advance
tony
Reply With Quote
  #2  
Old 02-02-2003, 01:07 AM
Registered User
 
Join Date: Dec 2002
Location: Whitley City KY
Posts: 28
Check the GP fuse located in the Glow Controller. It is a bar type fuse 80 amp secured by 2 screws. The GP controller is located on the left side tire well.
__________________
82 300SD
93 F250 4x4
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page